Home > Gentoo >

Gentoo php-apc 3.1.8 Failed opening required

Gerade eben habe ich ein Gentoo System aktualisiert. emerge meldete dass PHP gerne aktualisiert werden würde, wobei die Version weiterhin bei 5.2.17-pl0-gentoo bleibt. Als Abhängigkeit wurde php-apc auf Version 3.1.8 aktualisiert.

Seitdem erscheint auf diversen Webseiten Fehler dieser Art:

Fatal error: main() [function.require]: Failed opening required 'dateiname.php' (include_path='.:') in on line 429

Die Fehler erscheinen erst beim zweiten Klick auf die Webseite, was mich sofort an den APC Cache erinnert hat.
Nachdem APC deaktiviert ist erscheinen die Webseiten auch beim zweiten Klick wieder ganz normal.

Sobald ich (bzw. die Gentoo Entwickler…) eine Lösung gefunden habe, werde ich diesen Artikel aktualisieren.

// Nachtrag
Der Bug wurde mit der Einführung von APC 3.1.9 gelöst. Siege dazu auch meinen Bugreport unter: http://bugs.gentoo.org/show_bug.cgi?id=366489

KategorienGentoo
  1. Bisher keine Kommentare
  1. Bisher keine Trackbacks