Home > Debian >

apt-get / aptitude Problem GPG error: NO_PUBKEY

Die letzte Zeit gab es auf Debian Systemen (vorwiegend Debian Etch) beim ausführen von „apt-get update“ immer wieder einen Fehler dieser Art:

W: GPG error: http://security.debian.org etch/updates Release: 
Die folgenden Signaturen konnten nicht überprüft werden, weil ihr 
öffentlicher Schlüssel nicht verfügbar ist: 
NO_PUBKEY 9AA38DCD55BE302B
 
W: GPG error: http://ftp2.de.debian.org etch Release: 
Die folgenden Signaturen konnten nicht überprüft werden, weil ihr 
öffentlicher Schlüssel nicht verfügbar ist: 
NO_PUBKEY 9AA38DCD55BE302B

Die Lösung dieses Problems ist das nachinstallieren diverser GPG Schlüssel für apt unter Debian:

apt-get install debian-archive-keyring

Danach hat sich „apt-get update“ immer sauber ausführen lassen.

KategorienDebian
  1. 22. August 2011, 12:29 | #1

    Danke für den Tipp, nu gehts :)

    Aber das Tool heißt aptiTude, also mit t, nicht mit d.

  2. Dominik
    23. August 2011, 08:36 | #2

    Danke für den Hinweis

  1. Bisher keine Trackbacks